www.the351cforum.com

ALL things related to the Ford 351C
It is currently Sun May 22, 2022 6:07 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Jun 04, 2021 1:02 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1726
The problem for the 427C
Image

Hmm - light comes on. Need a fixture..how about a 3/4 pipe T
Image

They seem to protrude about .160~.180, so take a little off the top.
Image

All fixed
Image

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
PostPosted: Sat Jun 05, 2021 6:52 am 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:49 pm
Posts: 1339
Location: Orange County, NC
That's cool; progress.


Top
 Profile  
 
PostPosted: Tue Jun 08, 2021 8:43 pm 
Offline

Joined: Tue Nov 06, 2012 12:02 pm
Posts: 494
Plugging both ports? I thought one of them had to be open, depending on cleve vs windsor block.


Top
 Profile  
 
PostPosted: Wed Jun 09, 2021 2:41 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1726
The deck holes are plugged on a clevor, water returns to the radiator out the front of the head. The AFDs have 3/4 pipe thread ports on both ends of the head.

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group