www.the351cforum.com

ALL things related to the Ford 351C
It is currently Wed Feb 26, 2020 11:01 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2, 3  Next
Author Message
PostPosted: Fri Nov 14, 2014 10:04 pm 
Offline
User avatar

Joined: Wed Oct 31, 2012 8:43 pm
Posts: 335
Well guys started to work on installing vacuum pump on motor. Its not the typical install, as there are no real Cleveland specific brackets, however Star Machine seemed to have all the parts that worked perfect so far. They offer a sub plate that bolts top the left head. It has spacers that can be made to custom length. Then followed with install of the Blue mounting bracket for the pump.

Image

Image


Image

Image

_________________
Tim/Izzy/Alaina/Andrea


Top
 Profile  
 
PostPosted: Sat Nov 15, 2014 8:42 am 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 2652
Nice. You gonna plumb in a vac gauge somewhere?

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Sat Nov 15, 2014 10:11 am 
Offline
User avatar

Joined: Wed Oct 31, 2012 8:43 pm
Posts: 335
Hey Brent, Yes, I had the Moroso aluminum evac set up, found some nice aluminum two piece oil caps from GZ motorsports. One going to drill and tap for the engine to pump connection, the other for vacuum gauge for pump off valve cover, sound ok?

_________________
Tim/Izzy/Alaina/Andrea


Top
 Profile  
 
PostPosted: Sat Nov 15, 2014 1:19 pm 
Offline

Joined: Mon Oct 29, 2012 9:05 am
Posts: 2652
That's how I do it.

_________________
Brent Lykins, Lykins Motorsports
www.lykinsmotorsports.com
brent@lykinsmotorsports.com


Top
 Profile  
 
PostPosted: Sun Nov 16, 2014 12:05 am 
Offline
User avatar

Joined: Wed Oct 31, 2012 8:43 pm
Posts: 335
Thanks Brent, here is a pic of final setup, and a vid of the motor......Tim

Image


https://www.youtube.com/watch?v=m7kSmq8ESeg

_________________
Tim/Izzy/Alaina/Andrea


Top
 Profile  
 
PostPosted: Sun Dec 14, 2014 5:03 pm 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 1078
Location: Texas
Tim, I was curious. You have the Yates A3 heads right? so what headers did you install? Those heads have raised exhaust ports right?


Top
 Profile  
 
PostPosted: Wed Jan 21, 2015 1:22 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1170
What water pump are you running - so far, on the ProForm units I've tried the lower hose won't clear the balancer, either stock or aftermarket. The inlet "clears" but is so close to the outer ring that a host rubs the ring. They work fine on a 302, but won't work on the 351Cs.

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
PostPosted: Thu Jan 22, 2015 4:01 pm 
Offline
User avatar

Joined: Wed Oct 31, 2012 8:43 pm
Posts: 335
nova467spanker wrote:
Tim, I was curious. You have the Yates A3 heads right? so what headers did you install? Those heads have raised exhaust ports right?

Matt I have Ford A3 heads, not yates

_________________
Tim/Izzy/Alaina/Andrea


Top
 Profile  
 
PostPosted: Thu Jan 22, 2015 4:04 pm 
Offline
User avatar

Joined: Wed Oct 31, 2012 8:43 pm
Posts: 335
Falcon67 wrote:
What water pump are you running - so far, on the ProForm units I've tried the lower hose won't clear the balancer, either stock or aftermarket. The inlet "clears" but is so close to the outer ring that a host rubs the ring. They work fine on a 302, but won't work on the 351Cs.


Hey Chris,
I run a Meziere, HD 12V, it is a bit longer than the 42gpm. No fitment issues whatsoever

https://www.meziere.com/ps-743-711-wp111uhd.aspx

_________________
Tim/Izzy/Alaina/Andrea


Top
 Profile  
 
PostPosted: Fri Jan 23, 2015 9:36 am 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 1078
Location: Texas
My bad bro. Well i got those Patriot headers to fit-they slipped right in. pictures are in the "General Discussion" index if you have not seen them.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group