www.the351cforum.com

ALL things related to the Ford 351C
It is currently Tue Jul 05, 2022 8:21 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
PostPosted: Fri Jul 02, 2021 9:32 am 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1738
It starts and runs, sounds much better with the ASF32Cs in it now. The front shooter looks "weak" so I'm going to pull that bowl and replace the umbrella seal. Other than that, it's wait to test at the track. We're scheduled for a Saturday TnT tomorrow night and wife is scheduled to work the computer system - but the forecast is for rain most of the day.

I'm thinking this car will end up with most of the dragster ignition on it - I was looking at the crank trigger and Aerospace front drive last night thinking "hmmm". Just mo-money.

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
PostPosted: Sat Jul 03, 2021 7:36 am 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:49 pm
Posts: 1361
Location: Orange County, NC
I'm working on pulling the motor out of my 70 so I can freshen it up and drop it in my better half's 69 Cougar convertible so she can drive it again. I need to swap cams in it to something more powerbrakes and stock converter friendly. It will also need a distributor that is not locked out. I've been looking around trying to find a drop in electric unit that does not require an ignition box, and man, aint none of them cheap. It currently has a stock electric in it that had the advance plates welded. It's not fancy, but it always worked for what we were doing.


Top
 Profile  
 
PostPosted: Sat Jul 03, 2021 11:45 am 
Offline

Joined: Mon Nov 05, 2012 3:54 pm
Posts: 125
Falcon67 wrote:
I'm thinking it could have come from carb work on the dragster motor which regularly spilled alcohol around the intake. Would not take much for that to get into the cap, or be exposed when the cap was off.


Yeah, the spillage could have been the culprit. Yet, that is still mighty strange corrosion for a race car ditzy for sure!


Top
 Profile  
 
PostPosted: Mon Jul 12, 2021 9:42 am 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1738
At this time - I think I have it worked out. I went through the 650DP yesterday and replaced everything including the base gaskets, carb cleaned and blew it all out with compressed air, etc. Only thing I didn't change were the needle/seat and didn't pull out the emulsion tubes LOL. Put it on the car and the back needle stuck open - thanks a lot. Replaced that and it starts and runs good, makes all the right noises. The shooters are 37 and 39 and I can't find my notes so I will tinker with the shooters on Friday night if it works well enough out of the trailer. I thought they should be 37/35. I also have to remember that the 7AL-3 has a 25 degree retard until the engine gets past 1300 RPM, so have to burp it after starting to get back to 38 lead.

Image

I put every part except the crank trigger on the car, and will go back and eve put that on the car sometime later. I switched the alternator over from the old 6 rip setup that squealed everytime I started the car to a more simple belt. That gives me room to move the alternator around to accommodate the 3/8" thick trigger ring. I thought about that last night, that I should have put the trigger ring on there already since I spent a good hour on the lathe making spacers for the alternator bracket. I can shorten one I guess and make a 3/8 "washer" for the other. One thing I noticed is that the volt meter goes right to 13.8~14v vs climbing up slow with the 6 rib. The alt likes the belt way better. And the pulley is larger so it may not have to spin as high.

I'll know for sure this is the fix as we have a two day coming up this weekend.

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
PostPosted: Mon Jul 12, 2021 6:12 pm 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 1509
Location: Texas
Thats good man. My Summit brand 1 wire with only the fuel pump on at idle reads 14.55 +/- a few . I have the March serpentine set up but I left the pulley the alternator on it. Math says with this pulley I think im in the 16,000 rpm range and with the March pulley it will be in the 17,000 rpm range. I believe this alternator is rated at 18,000rpm so I should be good either way. Now when I turn that Spal 16" fan on it drops to 14.2 or so.


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 6:22 am 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:49 pm
Posts: 1361
Location: Orange County, NC
If that doesnt fix it, it's cursed and you need a priest or something. LOL


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 2:59 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:39 pm
Posts: 1738
kv racing wrote:
If that doesnt fix it, it's cursed and you need a priest or something. LOL


Truth - or time for a fishing boat.

_________________
Chris - Merkel, TX
http://raceabilene.com/kelly/hotrod
"Owner built, owner abused."


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 3:30 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:49 pm
Posts: 1361
Location: Orange County, NC
Falcon67 wrote:
kv racing wrote:
If that doesnt fix it, it's cursed and you need a priest or something. LOL


Truth - or time for a fishing boat.


I keep thinking about that a lot myself.


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 5:53 pm 
Offline

Joined: Tue Nov 06, 2012 10:23 am
Posts: 1509
Location: Texas
Fishing boat with a low compression Cleveland and TWIN TURBO'S :D


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 6:01 pm 
Offline
User avatar

Joined: Mon Oct 29, 2012 2:49 pm
Posts: 1361
Location: Orange County, NC
nova467spanker wrote:
Fishing boat with a low compression Cleveland and TWIN TURBO'S :D


LOL
Hell no.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group